Back to overview
Resolved

[Maintenance] Syncrent ID System

Jul 24, 2026 at 11:00pm UTC  –  Jul 25, 2026 at 2:00am UTC
Affected services
Platform
Authentication service

Resolved
Jul 25, 2026 at 2:00am UTC

Maintenance ended

Created
Jul 24, 2026 at 11:00pm UTC

We're upgrading our authentication system to strengthen our infrastructure and enhance your security.

Please be aware that our platform will not be available during this maintenance.
Saved sessions will be lost and all passkeys/2FA methods need to be set up again. All affected users have received further instructions via email.

If there are any further questions about this change, please don't hesitate to contact us. Our technical support is available for you 24x5.

We appreciate your patience as we make these critical improvements.

Sincerely yours,
The Syncrent Team
/le/